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 C H A P T E R  1                 
1Introduction
eMerge is a simple, desktop application that lets you personalize form 
letters and send them to people on the Internet. You can use our built-in 
tools to create lists of names and e-mail addresses, or import all the 
information you need from your existing databases.

• Create direct mail advertising campaigns.

• Customize your product announcements.

• Move your billing system online.

• Make everyone on your mailing list feel that they aren’t.

What’s 
in this guide

Installing eMerge (Chapter 2) describes the hardware and software 
you need to install and run eMerge. It also describes how to choose the 
best method of mail delivery for your particular circumstance.

Leon’s first campaign (Chapter 3) describes the steps you must follow 
to create and execute a typical eMerge campaign. It follows the example 
of Leon Gall’s first campaign for CD-Rome, an online service that allows 
people to order their favorite music from the CDs cataloged on the 
CD-Rome website.

Writing better form letters (Chapter 4) describes how to use variables 
to customize the messages you send using eMerge and make your letters 
more personal, more informative, and ultimately more useful to you and 
your customers.
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Managing your mailing lists (Chapter 5) describes how to use
eMerge to build and maintain your mailing lists. It shows you how
export your lists, import information from other applications, and
dredge through files and folders for Internet addresses. It also desc
some simple tools that make it easier to use your lists.

Trouble shooting (Chapter 6) describes the error messages and o
problems you might encounter when using eMerge. It also tells yo
how to contact Galleon Software’s Technical Support department

eMerge license agreement (Appendix A) is mostly just common
sense: Don’t give copies of our software away, and we’ll give you the
service we can. But you can read the rest, if you want.

Symbols and 
conventions

As you read through this manual, there are just a few symbols a
conventions you should be aware of.

! Warning: These messages provide information that helps you prev
such serious things as interruptions in service or loss of data. You sh
watch out for these warnings and make sure you understand them

Note: These messages provide information important to the smo
running of eMerge.

Choosing menu commands
To describe the menu commands you have to choose, we’ve adop
the following convention. Suppose, for example, you want to copy
something to the clipboard. As you probably know, first you must 
on Edit in the menu bar, and then choose Copy from the Edit men
 Using eMerge 7.
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In this guide, we say: From the menu bar, choose Edit > Copy.

To describe hierarchical menu commands, we simply extend the form
example, you might want to change the status of a message to Waiti

In this guide, we say: Choose List > Change Status> Waiting.

Contacting 
Galleon 
Software

The best way of getting in touch with us is through our site on th
World Wide Web at www.galleon.com, but here are some of our m
popular e-mail addresses:
 Using eMerge 8.
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Sales and Marketing: sales@galleon.com

Technical Support: support@galleon.com

General inquiries: info@galleon.com

You can reach us by fax at:

416-955-0696

Or you can send us a letter the old-fashioned way:

Galleon Software
366 Adelaide Street East—Suite 327
Toronto, Ontario, Canada
M5A 3X9

However you reach us, we’ll do our best to get back to you before the
of the business day. If you would like us to give you a call, please include
phone number in your message and the best times to contact you.
 Using eMerge 9.
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C H A P T E R  2
2Installing
eMerge

This chapter describes the hardware and software you need to install 
and run eMerge. It also describes how to choose the best method of 
mail delivery for your particular circumstance. 

What you need To run eMerge you need the following things:

• a Macintosh-compatible computer with at least 4 MB of RAM and 
running System 7.0, or later

eMerge does not run on the Macintosh Plus, SE, SE/30, Classic, or 
the PowerBook 100.

• Thread Manager

Thread Manager is built into System 7.5, and later. If you are running 
an earlier system, you must install Thread Manager following the 
instructions in “Installing Thread Manager” on page 18. We’ve 
included a copy of Thread Manager in the eMerge folder.

• MacTCP or Open Transport

• an IP connection to the Internet
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2Installing eMer
eMerge supports modem or direct network connections. It d
not support indirect Internet access through such online servic
America Online or CompuServe.

Installing 
eMerge

The procedure for installing eMerge depends on how you receiv
the application. 

If you downloaded eMerge from Galleon Software’s website or fr
another online service, then you received a password-protected 
archive, like the archive on the left. To install eMerge from a passw
protected archive, follow the procedure below.

If you purchased eMerge on a diskette, or if you are trying out the d
version of eMerge, then you received a self-extracting archive. To
install eMerge from a self-extracting archive, follow the procedu
“Installing eMerge from a self-extracting archive” on page 14.

If you received eMerge on a compact disc, follow the procedure i
“Installing eMerge from CD” on page 16.

Installing eMerge from a password-protected archive
If you downloaded eMerge from Galleon Software’s website or fro
another online service, then you received a password-protected arc
To install eMerge from a password-protected archive, follow these s
 Using eMerge 11.
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1) Double-click on the password-protected archive.

When you start this application it generates a unique control num
and you must enter the matching password to unlock the archi

2) Choose the unlocking method that best suits your needs and fo
the instructions as they appear. 

Unlock Now allows you to purchase the password with a credit
over the phone and unlock the archive right away.

Unlock Later allows you to purchase the password with a credit 
or a check by e-mail, fax, or regular mail. When the password is m
back to you, start the application again and enter the password.

When you enter the password, the archive application creates
self-extracting archive.
 Using eMerge 12.
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3) Double-click on the self-extracting archive.

4) Click Continue.
 Using eMerge 13.
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5) Choose where you want to save the eMerge application folder

click Save.

This display tracks the progress of the installation. When the install
is complete, the following message appears.

6) Click Quit.

At this point you’ve successfully installed the eMerge application. 

If your computer is running System 7.5 or later, you can skip to
“Configuring message delivery” on page 20. If you are running an ea
system, you must install Thread Manager following the instructions
“Installing Thread Manager” on page 18.

Installing eMerge from a self-extracting archive
If you purchased eMerge on a diskette, or if you are trying out the d
version of eMerge, then you received a self-extracting archive. To
install eMerge from a self-extracting archive, follow these steps.
 Using eMerge 14.
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1) Double-click on the self-extracting archive.

2) Click Continue.

3) Choose where you want to save the eMerge application folder
click Save.
 Using eMerge 15.
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This display tracks the progress of the installation. When the install
is complete, the following message appears.

4) Click Quit.

At this point you’ve successfully installed the eMerge application. 

If your computer is running System 7.5 or later, you can skip to
“Configuring message delivery” on page 20. If you are running an ea
system, you must install Thread Manager following the instructions
“Installing Thread Manager” on page 18.

Installing eMerge from CD
The eMerge CD is roomy enough to include three different versio
eMerge, and roomy enough that we don’t have to compress anyth
into an archive. This means that you just have to choose the version
want and copy its folder to your hard disk. The folder you choose
depends on the type of computer you’re using.

eMerge PPC contains a version of eMerge that is optimized to run
Power Macintoshes or Macintosh-compatible computers with a Po
PC processor. This version does not run on older Macintoshes.

eMerge 68K contains a version optimized to run on older Macinto
This version runs on Power Macintoshes, but it runs more slowly 
the version contained in eMerge PPC.
 Using eMerge 16.
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eMerge FAT contains a version of eMerge that runs optimally on any
of Macintosh computers. When you run it on a Power Macintosh,
uses Power PC code; when you run it on an older Macintosh, it u
68000 code. Choose this version, if you might run your copy of eM
on different computers. 

Note: The eMerge we distribute in archive format is the “FAT” ver
of the application. 

1) Insert the eMerge CD.

2) Choose the version of eMerge that best suits your needs and 
its folder to your hard disk.
 Using eMerge 17.
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With this you’ve successfully installed the eMerge application. 

If your computer is running System 7.5 or later, you can skip to
“Configuring message delivery” on page 20. If you are running an ea
system, you must install Thread Manager following the instructions b

Installing 
Thread Manager

eMerge cannot run without the Macintosh Thread Manager. Threa
Manager is built into System 7.5 and later. If you are running an ea
system, you must install Thread Manager by following these steps.

1) Open the eMerge folder you just installed.

2) Open the folder named Pre-System 7.5.
 Using eMerge 18.
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3) Drag-and-drop the extension named Thread Manager onto yo

System Folder. 

The Finder recognizes extensions as one those files that have sp
places in the System folder.

4) Click OK.

The Finder automatically places Thread Manager in your Extens
Folder. (For more information on system extensions, refer to 
manual that came with your computer.)

Connecting to 
the Internet

Your computer may be connected to the Internet through your L
Area Network, or you might connect over the phone using a mod
and point-to-point protocol (PPP). Whatever the case, eMerge use
connection to the Internet you already have in place. When you st
sending messages from eMerge, the application connects automat
There is nothing else for you to install. 
 Using eMerge 19.
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If you are not connected to the Internet, contact a local Internet se
provider for assistance. Their Technical Support department can h
you configure your computer to connect to the Internet.

Note: eMerge only supports direct IP access to the Internet. It doe
support indirect Internet access through such online services as Am
Online or CompuServe. If you are unsure of the type of Internet se
you have, contact your Internet service provider.

Configuring 
message 
delivery

eMerge comes largely preconfigured. The only fine tuning you may
to do concerns the way eMerge delivers messages. By default, eM
delivers its messages directly to each recipient’s mail server. If you
computer is protected by an Internet firewall, however, you will li
encounter problems with direct delivery.

To avoid these problems, eMerge offers three delivery options. 
To choose the option that is best for you follow these steps.

1) From the menu bar, select Edit > Preferences.

2) Click the Application tab.

3) Under SMTP Options, choose the Send Messages option that
suits your needs.

Direct Only: eMerge attempts to send its messages directly to e
recipient’s mail server. The benefits of this method are that you
not charged for e-mail sent directly to mail servers and many ser
can tell you immediately whether or not the message was se
successfully. On the other hand, direct connections can be slow
if they fail, you have to try again manually. Note: You cannot use
method if your computer is protected by an Internet firewall.
 Using eMerge 20.
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2Installing eMer
Mail Server Only: eMerge directs all messages through your mail se
This is the method you must choose if your computer is protecte
an Internet firewall. The other benefit of this method is that the de
of all your messages may take less time, since you are letting your
server do all the hard work of connecting to each recipient’s mail se
On the other hand, mail may actually take longer to get to the recip
and you may have to wait for as long as two days before your mail s
informs you of undeliverable messages.

Direct > Mail Server: You get the best of both worlds. eMerge first
to send each message directly to the recipient’s mail server. If it fa
sends the message through your mail server. You cannot use this
method if your computer is protected by an Internet firewall, ex
of course, to send messages to people on your side of the firew

4) If necessary, for Mail Server, enter the address of your mail se
You need to do this if you chose either the Mail Server Only op
or the Direct > Mail Server in step 3.

Registering 
eMerge

As a registered purchaser of eMerge, you are entitled to free techni
support and free upgrades to the current version of the application.
will also inform you of new versions of the application as they are rele

If you purchased eMerge from our online fulfillment center, then y
were automatically registered as the original purchaser of the softw
There is nothing more you have to do.

If you received eMerge on disk, then to be registered as the origin
purchaser of the software, you must send the registration form th
accompanied the Software to Galleon Software, or register online
through our website at www.galleon.com.
 Using eMerge 21.
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2Installing eMer
Upgrading 
eMerge

Although we’ve tried our darnedest to make eMerge as problem 
as possible, we won’t pretend it’s perfect. But we will promise to 
odically release upgrades to fix the problems with the current ver
that do come to light. 

You can download upgrades from our website at www.galleon.co
These upgrades take the form of small applications which patch y
original copy of eMerge. To perform the upgrade, follow the instruc
that come with the upgrade application.

When we’re not fixing the current version, we’re working on makin
next version of eMerge even better. Registered purchasers of eMe
are entitled to discounts on future versions of the product. Visit ou
website to learn about the most recent developments, or wait, and 
send an announcement to you—and everyone else on our mailing
 Using eMerge 22.
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C H A P T E R  3
3Leon’s first
campaign

Leon Gall runs a service on the Internet he calls CD-Rome. Customers 
browse through his site on the World Wide Web and order their favorite 
music from the CDs in his catalog. Leon has purchased eMerge in order 
to personalize the letters and announcements he sends to his customers 
and to mount other direct mail campaigns in an effort to attract more 
people to his site. This chapter describes the steps he follows to create 
and execute CD-Rome’s first eMerge campaign.

An eMerge campaign file consists of three parts:

The message header is the information that appears at the top of each 
message generated by the campaign, and is typically what appears in the 
list of messages in people’s in boxes. It shows them who the message is 
from and what the message is about.

The form letter is the template from which all the messages are 
generated. Typically it contains a number of variables that can have 
different values for each recipient on the mailing list.

The mailing list is the list of people who are to receive the message. 
It includes their e-mail addresses and all the other information needed 
in order to fill out the variables on the form letter. 
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When you send a message to one of the people on your mailing lis
eMerge builds that message by filling in the blanks on the form letter
the appropriate information from that person’s record. eMerge then
the standard message header at the top of the message, signs onto
Internet, and delivers the message.

When you send the message to everyone on your mailing list, every
of them receives a personal, customized message.

Creating a new 
campaign

Leon’s first eMerge campaign is a simple one. A number of his cus
ers recently ordered an album, and the orders have been delayed.
send them each a personal apology, Leon needs to follow these st

1) Open the eMerge folder.
 Using eMerge 24.
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2) Double-click on the eMerge application icon.

This form contains all three parts of the eMerge campaign: the
sage header, the form letter, and the mailing list. Since the letter
the list can both get quite long, we’ve made it possible to hide t
items when you aren’t editing them. To hide the letter, for exam
click on the triangle next to the Letter header. To reveal the le
click on the triangle again.
 Using eMerge 25.
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3) For Your Full Name, enter the name that you want to appear in

header of each message in this campaign.

4) For Your Internet Address, enter the Internet e-mail address t
you want to appear in the header. 

Note: There is no way to verify the e-mail address you enter in
field. So, be careful. If you enter your address incorrectly, there
be no way for the recipient to know who to respond to.

5) For Subject of Message, enter the title that you want to appea
the header. 

Composing the 
form letter

The form letter is the template from which all the messages are gener
Typically it contains a number of variables that can have different value
each recipient on the mailing list. In this example, Leon wants each le
to greet the recipients by their first name. 

1) Click in the Letter field and start typing.
 Using eMerge 26.
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2) To insert a variable, choose the variable name from one of the

menus above the letter.

Firstname is a standard eMerge variable that is filled using the n
you enter in the mailing list. For more information on the stan
variables you can use, refer to “The standard variables” on pag
To create your own custom variables, refer to “Creating your 
variables” on page 40.

Within the letter, variable names are enclosed by two sets of a
brackets and are displayed in color on color displays. 
 Using eMerge 27.
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3) Continue typing the letter.

Creating the 
mailing list

The mailing list is the list of people who are to receive the messa
includes their e-mail addresses and all the other information neede
fill out the variables on the form letter. To add people to a mailing
follow these steps.

1) To make more room for the list, you can close the letter by clic
the triangle next to the Letter header.

2) From the menu bar, choose List > New Recipient.
 Using eMerge 28.
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3) For First and Last Name, enter the full name of the recipient.

You can also enter an initial or as many middle names as you w
eMerge gets the value of firstname from the first word in this fi

4) For Internet Address, enter recipient’s e-mail address.

5) Click OK.

The recipient is added to the mailing list.

6) Repeat step 2 through step 5 for each person you want to ad
 Using eMerge 29.



gn

s are 
 look.
3Leon’s first campai

Previewing the 
messages

Before you send your messages, you should check that all the variable
being filled in correctly and that the letter looks the way you want it to

1) From the menu bar, choose Messages > Preview.
 Using eMerge 30.
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The standard variables are highlighted in green. (Don’t worry, this i
so you can identify them quickly; they won’t be green when the m
sage is sent.) Any variables that don’t have a value are highlighted i

2) To move through the mailing list, click Next.

3) When you are done, close the Preview window.

Saving your 
work

Before you attempt to send your messages, it is always a good idea to
all the work you’ve done. To save an eMerge campaign, follow these 

1) From the menu bar, choose File > Save.

2) For Save As, enter the name of your campaign.
 Using eMerge 31.
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3) Click Save.

The campaign is saved, and the new campaign name appears a
top of the campaign form.

Sending the 
messages

When you send your messages, eMerge builds each message by fi
in the blanks on the form letter with the appropriate information 
each recipient’s record. It then puts the standard message header a
top of the message, signs onto the Internet, and delivers the mess

To send a message to all the recipients on the mailing list, follow these 

1) From the menu bar, choose Messages > Send To All.
 Using eMerge 32.
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For each address, eMerge goes through a series of steps, that 
can watch in the progress window. This example shows eMerge
way through the sending process. It successfully sent the seco
message but failed to send the first message because the e-ma
server to which it was sending the message did not recognize
recipient’s user ID.

2) When eMerge has processed all the entries in the mail list, cli
Done to close the Progress window.

In this example, eMerge successfully sent all but two messages
second error indicates that eMerge could not find any mail se
named zone.com on the Internet.

Correcting 
addresses

To correct an entry in the mailing list, follow these steps.

1) Double-click on the entry in the mailing list.
 Using eMerge 33.
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2) Correct the information. 

In this example, Leon entered the wrong user ID for Raymond

3) Click OK.

4) Repeat step 1 through step 3 for each entry you want to corr

5) Select the entries you want to resend. 

To do this, select the first entry. Then, holding down the Comm
key, select the remaining entries.
 Using eMerge 34.
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6) Choose Messages > Send To Selected.

eMerge goes through the same process it went through before
only for the messages you’ve selected. 

This time, however, eMerge sends the two messages successfu
and Leon Gall’s first direct mail campaign is a compete succes
 Using eMerge 35.
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Saving the 
campaign

At this point, you can save your campaign. You may want to use the 
letter again, or you may eventually want to send a different messag
the same mailing list.

You can also save a campaign before eMerge has successfully deliv
all the messages. The status of each message in the campaign is sa
along with everything else, so you can later load the campaign and 
sending messages again where you left off.
 Using eMerge 36.
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4Writing better
form letters

While we cannot promise that eMerge will make you a better writer, we 
can say that your letters will be more personal, more informative, and 
ultimately more useful to you and your customers. Instead of sending 
the same, generic letter to everyone on your mailing list, eMerge allows 
you to customize every message you send.

To do this, eMerge offers a series of standard variables, or you can define 
your own. You can place variables anywhere in your letter and give these 
variables a different value for each recipient. When eMerge sends a 
message to a recipient, it inserts these values into the form letter.

The standard 
variables

eMerge maintains a series of standard variables that are available in 
every eMerge campaign. These are listed below.

• subject: The subject of the message. This is the value you enter in the 
message header.

Dear « firstname»,

How are things 
with the 
« lastname» family?

Dear  Raymond

How are things 
with the 
Ng family?

Raymond
Ng

Form letter + =Recipient Message
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• fullname: The full name of the recipient. This is the value in the 

and Last Name field on the New Recipient form, and is the sam
the name that you see on the mailing list.

• title: The recipient’s title. Mr., Mrs., Ms., and so on. If no title is fo
then this variable is empty.

• firstname: The recipient’s first name. If there is only one name in t
First and Last Name field, then eMerge assumes that it is the first n

• initial: The recipient’s middle initial. If no initial is found, then th
variable is empty.

• lastname: The recipient’s last name. If there is only one name in
First and Last Name field, then eMerge assumes that it is the fi
name and leaves this variable empty.

• email: The recipient’s e-mail address.

• count: The number of messages you’ve instructed eMerge to se
you send all the messages at once, this is the same as the tota
played on the mailing list.

• iteration: The position of the message in the list of messages that 
eMerge is sending. If you send all the messages at once, this is the 
as the number displayed next to each recipient on the mailing lis

• date: The date that the message is created by eMerge and sent
the short date format specified in the Date & Time control pan
your computer.
 Using eMerge 38.
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4Writing better form lette
• longdate: The date that the message is created by eMerge and 

in the long date format specified in the Date & Time control p
on your computer.

• time: The time that the message is created by eMerge and sen
the time format specified in the Date & Time control panel on 
computer.

How eMerge breaks up the full name
eMerge breaks each recipient’s full name into its components: title
name, middle initial, and last name. To determine these values, eMe
looks for the spaces in the full name that separate the componen

To determine the title, it looks at the characters before the first s
in the full name and matches this word against a built-in list of titl
this word is not a title, it assumes that it is the recipient’s first nam

To determine the middle initial, eMerge looks at the word after the
name. Middle initials consist of a single character or a single chara
followed by a period.

To determine the last name, eMerge works backward from the en
the full name. If there is only one name in the full name, then eMe
assumes that it is the first name and leaves the last name empty.

If you don’t like the way eMerge is breaking up a particular name,
can force the application to do things your way. For example, if you
Darrin Van Dyke to your mailing list, eMerge will assume that his 
name is Dyke. To force eMerge to recognize the entire last name, 
can enclose it in quotation marks—“Van Dyke”—or replace the s
 Using eMerge 39.
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with an underscore character—Van_Dyke. Either way, the message
send interprets the last name correctly as Van Dyke; it does not inc
the quotation marks or the underscore character in the final mes

Creating your 
own variables

eMerge fills in the standard variables automatically, but you can defin
to ten of your own custom variables and fill them in manually for e
recipient. To define the variables for a campaign, follow these steps

1) From the menu bar, choose Edit > Preferences.

2) Click the Campaign tab.

These are the ten custom variables you can use in the campai

3) Change the names so that you can more easily remember what
variable contains.
 Using eMerge 40.
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4) Click OK

Using variables Using variables in your form letters involves two steps: first you m
define where in the letter the variables appear, then for each recip
you must supply the value for each custom variable you’ve used in 
letter. In this chapter we describe how to enter these values by h
in the next chapter we describe how to import these values from
existing database.

Composing a form letter
To create a form letter with variables, follow these steps. As you writ
letter, you should keep in mind the different values your variables m
contain and make sure that the different messages will flow smooth

1) Begin typing the letter.
 Using eMerge 41.
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2) To insert a variable, choose the variable name from one of the

menus above the letter.

Within the letter, variable names are enclosed by two sets of a
brackets and are displayed in color on color displays. 

If you are a good typist and are loathe to take your fingers from
keyboard, you can enter the variables by hand. Remember to 
enclose the variable name in two sets of angle brackets. (Use 
greater-than and less-than characters.) As soon as you enter a 
 Using eMerge 42.
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label, eMerge recognizes it as such. If the label does not chang
color, you probably entered the name incorrectly.

3) Finish typing the letter, adding variables where you want them

In this example Leon Gall, is creating a campaign that let’s his 
customers know when he receives CDs that might interest th

Entering values
eMerge automatically fills the standard variables in your form lett
but it’s up to you to enter the values for the custom variables you
To enter these values you must perform the following steps for e
person on your mailing list. 

In this example, we’re assuming that you’ve already entered a list 
names and address. Alternatively, you can enter values for the cus
variables when you create each new recipient.
 Using eMerge 43.
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1) Double-click on the person’s name.

2) Click on the triangle next to Variables header.
 Using eMerge 44.
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3) Enter a value for each of the variables you’ve used in your form l

The text you enter can be as long as you want. We’ve given yo
window a little more than two lines high, but that shouldn’t stop
from entering paragraphs of text, or even whole letters. If you 
trouble editing such large amounts of text in such a small win
you can copy and paste it from any text editor.

4) Click Apply.
 Using eMerge 45.
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5) To see how these values look in the form letter, from the menu

choose Messages > Preview.

eMerge highlights the standard variables, your custom variables
any custom variables for which you have not entered a variable
highlights do not appear in the message eMerge sends.

If you don’t enter a value for a variable, eMerge displays the varia
name in its proper position in the preview and highlights it in red. I
example, Leon has not entered anything for Paul Abbott’s «P. S.». T
hide these unknown variables in the preview, deselect Show Unkn
Variables. This lets you see exactly what your message will look li
 Using eMerge 46.
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C H A P T E R  5
5Managing your
mailing lists

This chapter describes how to use eMerge to build and maintain your 
mailing lists. It shows you how to export your lists, import information 
from other applications, and dredge through files and folders for Inter-
net addresses. It also describes some simple tools that make it easier to 
use your lists.

Importing 
database 
records

The chances are pretty good that you already have a lot of useful contact 
information stored in a database. If you can save this information as a 
text file, you can import it into eMerge.

Before you can import your database records into eMerge, however, 
you must first create a text file in a format that eMerge can handle.

Choosing an import-export format
eMerge can handle records in the following standard formats:

To determine which format best suits your needs, refer to the docu-
mentation that came with your database application . eMerge also 
allows you to define a custom format, where you specify the character 
that marks the end of each field and another character that marks the 
end of each record.

• tab-delimited • merge

• comma-delimited • basic
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You must also instruct your database application to export the ke
fields of each record—the recipient’s name and the recipient’s Inte
address—in an order that eMerge can handle. eMerge recognizes
following field orders:

• FullName/Internet Address: the full name, followed by the full Inte
address

• Internet Address/FullName: the full Internet address, followed by
full name

• Internet Address/FirstName/LastName: the full Internet address, 
followed by the first name, and then the last name

When eMerge reads records in this format, it puts the firstna
and lastname together as the full name.

• Domain/UserID/FirstName/LastName: the portion of the Internet ad
that follows the @, followed by the portion of the address that proc
the @, followed by the first name, and then the lastname

When eMerge reads records in this format, it puts the pieces o
Internet address together into a full address (including the @) a
puts the firstname and lastname together as the full name.

Finally, place your variables in each record after these key fields. Make
to put them in the same order they appear in the campaign’s variabl
 Using eMerge 48.
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In the following example, Leon Gall has created a comma-delimited 
file from his database, and used the FullName/Internet Address field o
The records match the variables he defined in the example in Chap

Importing a text file
To import a text file into eMerge, follow these steps.

1) From the menu bar, choose File > Import.
 Using eMerge 49.
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2) Choose the options that match the format you used to expor

text file from your database application. These options are 
described in “Choosing an import-export format” on page 47

To prevent eMerge from importing records with blank addres
select Eliminate Blank Addresses.

3) Click Import.

The counter keeps track of the records as they are imported
 Using eMerge 50.
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4) Click Close when you’re done.

The imported records appear in your mailing list.

5) To check that the variables were imported correctly, double-c
on one of the recipients.
 Using eMerge 51.
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6) Click on the triangle next to the Variables header.

If you look back at the text file on page 49, you’ll notice that L
only entered values for the first four variables. When eMerge 
reaches the end of a record, it assumes that the remaining vari
are empty. In this example, Leon wants to enter the P. S. value
hand, but only for a few of his customers.

Dredging If you aren’t lucky enough to have a database full of potential custom
you can use eMerge to find them. Using the dredging function, eMerg
read through any file on your computer—or a whole folder full of fi
searching for Internet addresses and adding them to your mailing lis
 Using eMerge 52.
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Dredging files
To search through a single file for Internet addresses, follow these s

1) From the menu bar, choose Dredge > Dredge File.

2) Find the file you want to dredge and click Open.

eMerge displays the addresses as it finds them.
 Using eMerge 53.
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3) Click Close when you’re done.

The dredged addresses appear in your mailing list.

eMerge does the best that it can to interpret the user IDs in th
addresses it finds and uses this to fill out each recipient’s name. O
the person’s user ID is the same as his or her full name, and eM
recognizes this. For instance, in the fifth entry above, eMerge re
nized that a person with the user ID of jim_rolston is probably na
Jim Rolston. With some of the other addresses on this list, it w
quite so lucky.

! Warning: You should always check through dredged lists befor
using them. Depending on the contents of the files you dredge
information for some recipients may not be filled in completely
some records might contain incorrect addresses.
 Using eMerge 54.
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Dredging folders
If you have a lot of files to dredge, you can put them all in a single fo
and dredge the folder. You can even dredge every folder on your e
hard disk.

To dredge a folder, follow these steps.

1) From the menu bar, choose Dredge > Dredge Folder.

2) Find the folder or disk you want to dredge and click Select.
 Using eMerge 55.
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3) Select the dredge options you want.

Recursively Dredge Folders lets you dredge folders within folder
(within folders), no matter how deeply they’re nested.

Dredge Only Filetypes restricts the dredging to the file type you
specify. Otherwise, eMerge dredges all the files it finds.

Dredge Only Creators restricts the dredging to files created by 
application you specify.

4) Click Start

eMerge goes through the folder and dredges the files it finds. W
Happening shows you the file eMerge is currently working on.
 Using eMerge 56.
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5) Click Close when you’re done.

The dredged addresses appear in your mailing list.

Exporting a 
mailing list

Once you have taken the time to build a mailing list in eMerge, you
probably want to use it in another campaign or export it to anoth
application. For instance, you might just want to use eMerge to dre
for addresses and use your database application to process them fu

Exporting a list to another campaign
To use a list in another eMerge campaign, select the recipients you 
from the source list, copy, and paste them into the destination list

! Warning: When you copy recipients between lists, eMerge does not 
the names of the variables. It only copies the contents of each varia
and pastes them in the same position on the destination list. The con
of the first variable in the source list are pasted in the first variable o
destination list, the second in the second, and so on. 
 Using eMerge 57.
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If you aren’t careful, this can lead to problems. For example, sup
you are trying to combine two lists of customer information. If t
customer account number is in Variable 4 in one list, and in Varia
in the other list, you are going to encounter serious problems w
form letters that include the account number.

You should, therefore try to maintain some uniformity in the lists
create. If you still find yourself with two incompatible lists, you’ll h
to export them to a text file and coordinate them using a text ed
or your database application.

Exporting a list to another application
To export a list to another application, eMerge can write the conten
your list to a text file. The first thing to do is to determine the best fo
to use for your application. eMerge can export lists in the same for
it recognizes when importing lists. Refer to “Choosing an import-ex
format” on page 47.

To export a mailing list, follow these steps.

1) From the menu bar, choose File > Export All.
 Using eMerge 58.
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2) Choose the options that match the format that best matches the n

of the application into which you’ll be importing the file. These op
are described in “Choosing an import-export format” on page 4

3) If you want to export the variables along with the names and 
addresses, make sure that Export Variables is selected. If you j
want to export the names and addresses, make sure that Expo
Variables is not selected.

4) Enter a value for Creator and File Type.

These determine what type of file eMerge creates. If you leave t
fields blank, eMerge creates a generic Macintosh text file.

5) Click Export.

6) For Save As, enter the name of the text file you’re exporting.

7) Click Save.
 Using eMerge 59.
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eMerge counts through the records as it exports them.

8) Click Close when you’re done.

Sorting a list eMerge allows you to sort your mailing list on any of the fields that ap
in the list. To sort on a field, click on that field’s name in the list heade
can click on First Name or Last Name, User ID or Domain Name, a
Status. Option-clicking on a field sorts the records in reverse order.

Sorting on names and addresses put the records into alphabetical o
Sorting on Status moves duplicate addresses together to the top o
list, followed by any addresses that generated errors when you 
attempted to send a message to them.

Note: You cannot sort your mailing list on any of your custom vari

Searching a list eMerge allows you to search for a string of characters in your ma
list. To search for a string, follow these steps.

1) From the menu bar, choose List > Find.
 Using eMerge 60.
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2) For Find Text, enter the string you are searching for.

You can restrict the search to the Internet addresses, the name
the variable fields. 

3) Click Find First.

eMerge highlights the first record in the list that contains the s
you are searching for. 

4) To take a quick look at the variables for that record, Control-
on the record.
 Using eMerge 61.
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5) To edit a variable, select it from this pop-up menu.

Selecting 
recipients

eMerge offers a few tools to make it easy to select recipients from 
mailing list. 

Selecting individual recipients
If you want to select a number of recipients throughout the list, c
on the first person, then Command-click on the remaining people

Selecting recipients by their status
To select all the recipients with a particular status, from the menu
select List > Select Status, then the status you want to select.

Alternatively, you can use the select menu below the mailing list.
 Using eMerge 62.
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C H A P T E R  6
6Trouble
shooting

This chapter describes the error messages and other problems you 
might encounter when using eMerge. It also tells you how to contact 
Galleon Software’s Technical Support department.

Contacting 
Technical 
Support

As a registered purchaser of eMerge, you are entitled to free technical 
support through Galleon Software’s site on the World Wide Web. We 
suggest you try there first. That’s where you’ll find the latest update to 
the application and lists of frequently asked questions.

If you want to contact Galleon Software’s Technical Support department, 
send a message describing your question to:

support@galleon.com

Or you can reach us by fax at:

416-955-0696

However you reach us, we’ll do our best to get back to you before the end 
of the business day. If you would like us to give you a call, please include your 
phone number in your message and the best times to contact you.
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Reporting 
problems

If you discover any problems with eMerge or if you have any idea
improving the product, we’d like to hear from you. Without feedb
from our customers, we’d be working in a vacuum. Please send yo
messages to:

development@galleon.com

Status messages The following is a list of the status messages that appear in the mailing
Consult this list when you are having problems sending a message, o
when you need more information on the status of a particular reco

• Waiting: eMerge is waiting for you to send a message to this add

• Queued: You have instructed eMerge to send a message to this
address. The message is waiting its turn in the message queue.

• Sending: eMerge is in the process of sending a message to this
address.

• Successful: eMerge has successfully sent a message to this addr

• Error: When eMerge was sending a message to this address, it 
encountered an unknown error. This is usually the result of a 
lem with the network, a connection error, or a problem with 
MacTCP or Open Transport. 

You should try resending the message. If the problem persists, c
tact your network administrator or your Internet service provi
 Using eMerge 64.
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• User ID??: eMerge successfully connected to this recipient’s ma

server, but the user ID was not found on the server. 

Verify the user ID and try sending the message again. The user
might be invalid or it may have been deleted from the mail ser

• Site ID??: eMerge could not find this recipient’s mail server on
Internet. 

Verify the domain name and try sending the message again.

• Duplicate: The address for this recipient is the same as another
address in this mailing list. 

eMerge prevents you from sending the same message more tha
once to the same person. Correct the address, if you mistakenl
duplicated an address; or delete one of the recipient’s duplicate
records, but make sure that you delete the correct record.

• Dredged: This recipient was just found in a dredged file. 

Getting more information
To get more information on the status of a recipient, click on the tri
next to the status message.
 Using eMerge 65.
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The following are the messages you can find in this little display:

• Error: The error code that corresponds to the status message.

• Attempts: The number of times you have attempted to send a mes
to this recipient.

• Date: The date of the last attempt.

• Time: The time of the last attempt.

• Number of occurrences: The number of times an address was fo
in a dredged file.
 Using eMerge 66.



Using eMerge 67.

A P P E N D I X  A
AeMerge license
agreement

If you downloaded the eMerge application and the accompanying 
documentation (the “Software”) from Galleon Software’s online fulfillment 
center, then by decompressing the archive for the Software, or by using 
the Software, you acknowledge that you have received and read this 
Software License Agreement (the “Agreement”) and that you agree to be 
bound by it. If you do not want to enter into this Agreement, you may 
return your enabling password together with your receipt within 30 days 
to the place you obtained the Software for a full refund. Until return of this 
package has been accepted, you are governed by this Agreement.

If you received the Software on disk, then by opening the disk package 
for the Software, you acknowledge that you have received and read this 
Agreement and that you agree to be bound by it. If you do not want to 
enter into this Agreement, you may return the disk and all the material 
that accompanied it together with your receipt within 30 days to the 
place you obtained the Software for a full refund. Until return of this 
package has been accepted, you are governed by this Agreement.

License Galleon Software hereby grants you, the original purchaser, a paid-up, non-
transferable, non-exclusive license (the “License”) to use the Software 
subject to this Agreement.

Single computer: You may use one copy of the Software on a single 
computer at a single location. You may transfer the Software from one 
computer to another provided that you do not use or permit the usage 
of the Software on more than one computer at the same time.
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Copies: You may not copy or duplicate the Software, except as nece
for archival purposes, application error verification, or to replace defe
storage media. You agree to retain the Software and all such copies in
possession.

Restrictions and transfer: Except as permitted by this paragra
you may not sublicense, lease, rent, lend, or distribute the Softwar
any lawful copies thereof; or otherwise transfer any of your rights
under this Agreement. You may transfer the Software (together wi
back-up copies you have made) on a permanent basis to a third p
so long as you retain no copies, and the transferee agrees to be bo
by the terms of the Agreement.

Term: The License is effective until terminated. You may termin
the license at any time by destroying the Software together with
the copies you have made. The license is automatically terminate
you violate any portion of this Agreement. You agree upon any s
termination to destroy the Software together with all copies you 
made. Upon termination, there will be no refund of any monies 
you except in connection with the 30-day return policy set fort
above. Termination of this License shall be in addition to and not
lieu of any other remedies available to Galleon Software.

License 
registration

If you purchased the Software from our online fulfillment center, then
were automatically registered as the original purchaser of the Softw
If you received the Software on disk, then to be registered as the or
purchaser of the Software, you must send the registration form tha
accompanied the Software to Galleon Software, or register online on
site on the World Wide Web.
 Using eMerge 68.



nt

lleon 
he 
ers.

ent 
ered 
lable. 

e.

ation 
ware 

pile, 
f the 
he 

t 
nties 
ther 
ding 
ined 
ality, 
ility 
AeMerge license agreeme
Continuing 
support

Registered purchasers of the Software are entitled to free technical 
support through Galleon Software’s site on the World Wide Web. Ga
Software retains the right to begin charging for technical support in t
future, but will not do so without first notifying all registered purchas

Continuing 
fulfillment

If Galleon Software elects, at its sole discretion, to produce subsequ
updates and revisions to the Software (collectively “Updates”), regist
purchasers are entitled to receive such Updates as they become avai
Galleon Software reserves the right to charge for Updates. Unless 
otherwise noted, all Updates are subject to the terms of this Licens

Copyright 
protection

The Software is owned by Galleon Software, and its structure, organiz
and code are the valuable trade secrets of Galleon Software. The Soft
also is protected by Canadian and International copyright law. 

Restrictions You agree not to modify, adapt, translate, reverse engineer, decom
disassemble, or otherwise attempt to discover the source code o
Software. You may not alter or modify in any way the archive for t
Software, or create a new archive for the Software.

Limited 
warranty and 
disclaimer of 
warranty

The Software and related materials are provided “as is” withou
warranty of any kind, either express or implied, including warra
of merchantability or fitness for any particular purpose or any o
statutory or common law warranties. No warranty is made regar
the performance of the Software or the results that may be obta
by using the software. The entire risk as to the installation, use, qu
and performance of the software is with you. It is your responsib
to verify the results obtained from use of the Software.
 Using eMerge 69.
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Some jurisdictions do not allow the limitation or exclusion of imp
warranties, so the above limitation or exclusion may not apply to 
This warranty gives you specific legal rights and you may also have o
rights which vary. This disclaimer of warranties and the followi
limitation of liability shall not be modified, diminished, or affected
and no obligation or liability will arise or grow out of the renderin
technical, programming, or other advice or service or the provisio
support for the Software by Galleon Software.

Limitation of 
remedies

In no event will Galleon Software be liable to you for any conseque
incidental, or special damages, including but not limited to any lost 
revenues, profits, or savings, even if Galleon Software has been adv
of the possibility of such damages, or for any claim by any third pa

Some jurisdictions do not allow the limitation or exclusion of liab
for incidental or consequential damages so the above limitation o
exclusion may not apply to you.

Governing Law 
and General 
Provisions

This Agreement will inure to the benefit of Galleon Software, its succes
and assigns and will be construed under the laws of the Province of On
except for that body of laws dealing with conflict of laws. If any provisi
this Agreement is deemed invalid by a court of competent jurisdiction,
provision shall be enforced to the maximum extent permitted, and th
remainder will remain in full force.

Copyright © 1997 by Galleon Software, Inc. All unpublished-rights
reserved under the copyright laws of Canada by Galleon Software
366 Adelaide Street East—Suite 327, Toronto, Ontario, M5A 3X9. 
Galleon Software, the Galleon Software logo, eMerge, and the eM
logo are trademarks of Galleon Software, Inc.
 Using eMerge 70.
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problems 63–66
registering 21
starting 24–25
upgrading 22

Entering values 43–46
Error field 66
Error messages 64
Errors 63–66
Export Variables option 59
Exporting mailing lists 58–60
Exporting variables 48–49

F
FAT versions 17
Field Separators field 47
File formats

basic 47
comma-delimited 47
custom 47
import-export 47–49
merge 47
tab-delimited 47

File Type field 59
Files, dredging 53–54
Find command. See Searching maili
Find in First & Last Name option 
Find in UserID & Domain option 
Find in Variables option 61
Find Text field 61
Firewalls, and mail delivery options
First and Last Name field 29
Firstname variable 38
Folders

dredging 55–57
searching for recipients in 55

Form letters
composing 26–27
hiding and revealing 25, 28
previewing 30–31, 46
resending 34–35
sending 32–35
sending problems 33, 64–66

Full name
breaking up into components 
overriding break up 39–40

Fullname variable 38
FullName/Internet Address impor

export format 48
 Using eMerge 72.
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 21

7–58

21
Ind
G
Green, highlights in preview 31

I
Import-export format 47–49
Importing mailing lists 47–52
Importing variables 48–49, 52
Initial variable 38
Inserting variables 27, 41–43
Installing eMerge 10–22

from compact discs 11, 16–18
from password-protected archives 

11–14
from self-extracting archives 11, 

14–16
Installing Thread Manager 18–19
Internet Address field 29
Internet Address/FirstName/LastName 

import-export format 48
Internet Address/FullName import-

export format 48
Internet connections 10–11, 19–20
IP connections 10–11, 19–20
Iteration variable 38

L
Lastname variable 38
Letters. See Form letters
License agreement 67–70
Lists. See Mailing lists
Longdate variable 39

M
MacTCP 10

Mail delivery. See Message deliver
Mail Server Only message delivery
Mailing lists

building 52–57
copying between campaigns 5
creating 28–30
exporting 58–60
hiding and revealing 25, 28
importing 47–52
managing 47–62
searching 60–62
selecting entries 62
selecting entries by status 62
sorting 60

Managing mailing lists 47–62
Menu commands, choosing 7–8
Merge file format 47
Message delivery

configuring 20–21
Direct > Mail Server option 
Direct Only option 20
Mail Server Only option 21

Message headers 26
Messages

previewing 30–31, 46
resending 34–35
sending 32–35
sending problems 33, 64–66

N
Notes 7
Number of occurrences field 66

O
Open Transport 10
 Using eMerge 73.



Iex
53–54

46

ailing 
Ind
P
PPC versions 16
Pre-System 7.5 folder 18
Previewing messages 30–31, 46
Previews, highlighted variables in 31, 46
Problems

and solutions 63–66
reporting 64

Progress windows 32–33

Q
Queued message 64

R
Recipients

adding to mailing lists 28–30
editing data 33–35, 43–46, 61–62
Searching for 52–57
searching lists 60–62
selecting 62
selecting by status 62
sorting 60

Record Separators field 47
Recursively Dredge Folders option 56
Red, highlights in preview 31
Registering eMerge 21
Reporting problems 64
Requirements 10–11
Resending messages 34–35

S
Searching folders for recipients 55–57
Searching for recipients 52–57
Searching mailing lists 60–62

Searching text files for recipients 
Selecting menu commands 7–8
Selecting recipients 62
Selecting recipients by status 62
Sending message 64
Sending messages 32–35

Problems 33, 64–66
See also message delivery

Show Unknown Variables option 
Site ID?? message 65
SMTP options 20
Sorting mailing lists 60
Standard variables 37–40
Starting eMerge 24–25
Status details, revealing 65
Status messages

display 65–66
dredged 65
duplicate 65
error 64
queued 64
sending 64
site ID?? 65
successful 64
user ID?? 65
waiting 64

Status, using to select entries in m
list 62

Subject of Message 26
Subject variable 37
Successful message 64
Symbols and conventions 7–8
Symbols, in procedures 7–8

T
Tab-delimited file format 47
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39–40

 56–57
Ind
Technical Support, contacting 63
Text files

dredging 53–54
exporting to 58–60
importing from 47–52
searching through for recipients 

53–54
Thread Manager 10

installing 18–19
Time field 66
Time format, specifying 38–39
Time variable 39
Title variable 38
Triangle controls 25, 28, 44, 52, 65
Troubleshooting 63–66
Typing variable names 42–43

U
Updates, downloading 22
Upgrading eMerge 22
User ID?? message 65
Using variables 27, 37–46

V
Variable lists

copying between campaigns 57–58
hiding and revealing 44, 52

Variables
breaking up the full name 39–40
count 38
creating 40–41
custom 40–41
date 38
editing 43–46, 61–62
email 38

empty 46
entering values for 43–46
firstname 38
fullname 38
importing and exporting 48–4
initial 38
inserting 27, 41–43
interation 38
lastname 38
longdate 39
overriding full name break-up 
standard 37–40
subject 37
time 39
title 38
typing variable names 42–43
unknown 46
using 27, 37–46
viewing shortcut 61

W
Waiting message 64
Warnings 7
What’s Happening field 32–33, 53,

Y
Your Full Name field 26
Your Internet Address field 26
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